[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Problem with linux

From: John Clark
Subject: Re: [Discuss-gnuradio] Problem with linux
Date: Fri, 26 Jan 2007 17:53:23 -0800
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv: Gecko/20060910 SeaMonkey/1.0.5

Eric Blossom schrieb:
On Wed, Jan 24, 2007 at 05:00:13PM -0800, John Clark wrote:
Ok, I've been setting up a system which is based on the Linux kernel
and now have tried using the USRP device...

Well, if it worked I wouldn't be posting... the device is seen in a 2.6.17 kernel,
however, not in the

I see a dmesg output which indicates that the device is detected at some level,
but the python script cacs on 'Unable to find USRP #0', even thought when
I use USBVIEW it is seen and correctly identified as the USRP device.

Sounds like a problem in libusb and/or a changed interface to usbfs.

While I don't have an exact explanation, when I disable the USB 'USB selective suspend/resume and wakeup' option of the kernel USB driver configuration, I'm able to use the USRP in the kernel. I checked that against the setup in the kernel, and although this option is enabled in the setup, it does
not seem to have the same failing result.

I checkd it by turning the option off... compling, installing, booting, running the GNURadio program we developed without failure, then turning the option back on... testing, seeing failure... then turning the option back off and seen correct

So, I think there is some problem here... but I can't identify further exactly what...

John Clark.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]