[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: FOSDEM and beyond (next stable release of base)

From: Richard Frith-Macdonald
Subject: Re: FOSDEM and beyond (next stable release of base)
Date: Thu, 11 Feb 2010 08:04:52 +0000

On 9 Feb 2010, at 22:51, Riccardo Mottola wrote:

>> In this release, move to compatibility with the Apple objc runtime as much 
>> as possible.
> What does this mean? are we going to require libobjc2 ??

I meant that we should use the libobjc2 API as our 'standard' going forward so 
that, rather than having wrapper functions to convert all  runtime functions 
and data structures to our own version, we use the libobjc2 API directly where 
possible, and use wrappers to convert other runtime APIs to the libobjc2 
version.  This would make it possible to port future Cocoa code to GNUstep with 
less effort. 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]