[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] getdate: rename to get_date

From: Jim Meyering
Subject: Re: [PATCH] getdate: rename to get_date
Date: Fri, 01 Oct 2010 07:45:17 +0200

Bruno Haible wrote:
>> >  my suggestion implied to rename the function as well, not
>> > only the module :-)
>> At which point _all_ clients would instantly be exposed to the rename in
>> C code
> If we decide to rename get_date() to parse_datetime(), we can add a
>   #define get_date parse_datetime
> for one year or so, so that maintainers have all the time they need to
> react on the deprecation warning.

Hi Bruno,

That suggestion makes the sweeping name change palatable.
If you make that change, please ensure that the transition
definition is enabled only via the deprecated getdate module.
Thus, there will be no risk that those who upgrade will
forget to rename uses of the get_date function.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]