[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: poll: get_date: rename to parse-duration?

From: Eric Blake
Subject: Re: poll: get_date: rename to parse-duration?
Date: Mon, 04 Oct 2010 06:31:19 -0600
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100921 Fedora/3.1.4-1.fc13 Mnenhy/0.8.3 Thunderbird/3.1.4

On 10/02/2010 06:41 AM, Bruno Haible wrote:
Hi Jim, all,

If you make that change, please ensure that the transition
definition is enabled only via the deprecated getdate module.

OK. So, assuming that there is a smooth transition, and that only
the transition module provides the old names, let's make a poll.

Who is in favour, who is against
   - renaming the module to 'parse-datetime',
   - renaming the header file from getdate.h to parse-datetime.h,
   - renaming the function from get_date to parse_datetime?

The sweeping rename works for me as well; leaving 'getdate' as the only compatibility layer. Once a maintainer migrates to the new module name, they are already committed to fixing up all of the fallout.

Eric Blake   address@hidden    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

reply via email to

[Prev in Thread] Current Thread [Next in Thread]