[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: quotation marks [was Re: TUTORIAL.de updated]

From: Alan Mackenzie
Subject: Re: quotation marks [was Re: TUTORIAL.de updated]
Date: Sun, 22 Jan 2012 10:22:16 +0000
User-agent: Mutt/1.5.21 (2010-09-15)

Morning, Paul.

On Sun, Jan 22, 2012 at 12:00:15AM -0800, Paul Eggert wrote:
> On 01/21/2012 12:59 AM, Alan Mackenzie wrote:

> > Because fewer people are using tty environments (which is
> > basically what is meant here by "ASCII-only") ...

> No, by "ASCII-only" I meant displays that can display only ASCII.
> I use tty environments all the time, and they're never ASCII-only.


> > I have an ordinary Linux tty, currently running a Latin-1
> > character set....  I don't know how to do this, and finding out
> > is going to be a lot of work.

> It shouldn't be a lot of work.  I don't normally use the Linux
> console, but I looked into this problem and on my Ubuntu desktop
> the fix is simple:

>   export LC_ALL=en_US.utf8
>   setupcon

> After executing these two shell commands, I can see directed
> quotes ‘like this’ with no problem, both within Emacs and when
> catting to the terminal.  If it matters, I'm running Ubuntu 11.10
> x86 on a 5-year-old desktop.

> Does this approach work for you?

So far I've been at it about 1½ hours and got nowhere.  I tried setting
LC_ALL (to en_UK.utf8), but haven't got `setupcon'.  So I tried Gentoo's

    # /etc/init.d/consolefont restart

, no joy.  Then I grepped through Gentoo's repository index for setupcon,
finding nothing.  Then wikipedia - Nothing.  Then Google - Hah!  I found
a man page.  This talks about /etc/default/console-setup, yet gives no
pointer to a description of that file.

At this point I get the familiar feeling of being on a wild goose chase,
which happens about every time I need to configure something new on Linux
(thankfully, GNU is much easier).

So a reversion to logic - whatever utility I use to set the font, that
font must exist in /usr/share/consolefonts.  But the font I'm already
using, lat1-16.psfu.gz, allegedly "[has] a built-in Unicode mapping",
whatever that might be.  Yet I don't get the curly quotes displayed in
Emacs (or anywhere else).

> "It shouldn't be a lot of work."

Maybe not, but there can be a large gap between "shouldn't be" and "won't

Maybe you could give a run through of a hypothetical sequence of steps a
tty user would go through to find out how to set up his console for this.

Up to now it's taken nearly 2 hours now to get absolutely nowhere.  Maybe
I'm unusually inept at this sort of thing, but I don't think so.  I had a
head start by virtue of your help, for which thanks, but that misses the
point, that it will be very strenuous for a normal tty user to get set up
to see these curly quotes.

Alan Mackenzie (Nuremberg, Germany).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]