[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Require Emacs >=24.3 for next Org versions?

From: Achim Gratz
Subject: Re: Require Emacs >=24.3 for next Org versions?
Date: Sun, 16 Aug 2015 08:27:25 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.0.50 (gnu/linux)

Richard Stallman writes:
> Emacs 23 was current just a few years ago.  Please don't rush to
> desupport it.

It's not so much that we want to desupport it, we really want and need
to use some of the new features in Emacs24, namely lexical bindings.

> It is ok of the Org mode included in the current Emacs
> does not work in any other version, but when you distribute something
> separately, you should respect people that don't update often.

We don't have the developer resources to develop two different
distributions in parallel, just as Emacs doesn't seem to have the
developer resources to provide API compatibility between releases.  I
can't just say something like (require emacs23-compat), develop to the
Emacs 23 API and have Emacsen younger than that do the right thing for
my package.  I haven't done a formal survey, but I know of several
packages on ELPA that have already cut off Emacs 23.

Now, even if we did keep an Emacs 23 compatible Org around (most likely
being feature frozen and only getting critical bugfixes) we'd still have
to solve the problem that Emacs' package manager currently can't serve
different packages for different versions of Emacs.

+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Factory and User Sound Singles for Waldorf Blofeld:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]