[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] GPSD Client Connected to Remote GPSD - Unrecognized req

From: Joshua Quesenberry
Subject: Re: [gpsd-users] GPSD Client Connected to Remote GPSD - Unrecognized request "" when running gpsmon
Date: Tue, 5 Jun 2018 21:02:38 -0400

Two system setup. System 1 has both an internal and external GPS. I want this 
system to use the external GPS exclusively. System 2 has an internal GPS, but I 
want it to use the external GPS connected to system 1. This system's gpsd 
instance should connect to the gpsd instance on system 1 that is using the 
external GPS. The external GPS is much better quality than the internal GPS 
units, so I want its data instead of the others.

System 1 GPSD started using:

sudo /usr/sbin/gpsd -N -G -n -D 2 -F /var/run/gpsd.sock /dev/ttyUSB0

System 2 GPSD started using:

sudo /usr/sbin/gpsd -N -n -D 2 -F /var/run/gpsd.sock gpsd://

-F and specifying the device is how we've been running gpsd for years, never 
had an issue before. Why -F, not sure exactly why, but I've seen similar 
command format used on other vendors hardware that uses gpsd. We're specifying 
the device because we have multiple GPS units present and want to make sure the 
right one is used.

cgps and gpsmon were both used to try and view the data. cgps was provided with 
the gpsd-clients package and gpsmon was provided with the gpsd package and is 
referenced on: 

Both applications present this message on System 2 when started:

gpsd:CLIENT: => client(0): 
gpsd:CLIENT: <= client(0): ?WATCH={"raw":2,"pps":true}\x0d\x0a
gpsd:CLIENT: => client(0): 
gpsd:CLIENT: => client(0): {"class":"ERROR","message":"Unrecognized request 

And on System 1 as a result of both applications on System 2 sending a JSON 
watch command:

gpsd:CLIENT: <= client(0): ?\x0a
gpsd:ERROR: ERROR response: {"class":"ERROR","message":"Unrecognized request 
gpsd:CLIENT: => client(0): {"class":"ERROR","message":"Unrecognized request 
gpsd:CLIENT: <= client(0): WATCH={"enable":true,"json":true};\x0a
gpsd:CLIENT: => client(0): =

This output is very similar to what was discussed in this post: 


Josh Q

-----Original Message-----
From: gpsd-users [mailto:address@hidden On Behalf Of Gary E. Miller
Sent: Tuesday, June 5, 2018 8:13 PM
To: address@hidden
Subject: Re: [gpsd-users] GPSD Client Connected to Remote GPSD - Unrecognized 
request "" when running gpsmon

Yo Joshua!

On Tue, 5 Jun 2018 18:46:13 -0400
"Joshua Quesenberry" <address@hidden> wrote:

> As mentioned in the original post, I've tried using gpsmon and cgps,

I'm confused, and I have not bothered to keep copies of your earlier posts.

Can you resend your complete setup in one message?

> both of which were installed fresh using apt-get.

gpsd does not supply or support anything that needs apt-get.  We can only 
support our tar balls and git.  You are not using our software so it is hard to 
support you.

 The command being
> run on the client is:
> sudo /usr/sbin/gpsd -N -n -D 2 -F /var/run/gpsd.sock
> gpsd://
> So isn't this the same situation as mentioned in the other post I 
> listed? What you called master/slave?

Also, can you answer the question I have asked before?  Why are you using -F 
and a remote device on the slave?  Why are you using -F and a device on the 
master?  Those are very uncommon configurations that lead to problems.

New question: why would you ever use master/slave?  It buys you nothing that 
other configurations can't do better.  It has never worked well as no one uses 

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703
        address@hidden  Tel:+1 541 382 8588

            Veritas liberabit vos. -- Quid est veritas?
    "If you can’t measure it, you can’t improve it." - Lord Kelvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]