[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Lilypond build trouble

From: David Boersma
Subject: Re: Lilypond build trouble
Date: Fri, 31 May 2002 16:03:43 +0200 (CEST)


I also tried in vain to compile the 1.5.59 sources on a Red Hat (6.2 I
think) linux machine in our institute; although the failure is for a
slightly different reason. The output of the command...:

rurik:lilypond-1.5.59:1008$ ./configure --prefix=/stage/rurik/emin/davidb

...ends with:

WARNING: Please consider installing optional programs:  pktrace

ERROR: Please install required programs:  gcc 2.8 (installed:
egcs-2.91.66) c++ 2.95 (installed: egcs-2.91.66)

See INSTALL.txt for more information on how to build LilyPond
Remove config.cache before rerunning ./configure

The INSTALL.txt says that 'EGCS 1.1 may work but is no longer supported.'
With 2.91.66 I first naively thought that I was safe, but `rpm -qi egcs`
tells me that while the program version is 2.91.66, the source rpm version
is 1.1.2-30. This is confusing, not by lilypond's fault, but I think it
would be useful to mention BOTH numbers in the INSTALL.txt. And since the
configure script refuses to produce Makefiles for gcc=egcs-2.91.66, the
phrase 'may work but' should be replaced by 'will not work and'.

I am a bit surprised, though; all linux machines in our institute seem to
have egcs-2.91.66, also the relatively recently installed ones (one year
ago), so it seems a bit drastic to me to stop support for this compiler.
Version 1.4.13 compiles without problems, though (except for the docs).

David Boersma

reply via email to

[Prev in Thread] Current Thread [Next in Thread]