[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Lilypond 2.20 on Mac 10.15

From: Moritz Heffter
Subject: Re: Lilypond 2.20 on Mac 10.15
Date: Thu, 26 Mar 2020 10:36:08 +0100

Hum, I’ve tried out different settings now and also updated the system to the 
version 10.15.4 but it’s still the same error. I've also deactivated FileVault 
and gave.

The log file says maybe a bit more precisely:

Error Code:      0x00000004 (no mapping for user data read)
Trap Number:     14


> Am 24.03.2020 um 17:41 schrieb Hans Åberg <address@hidden>:
> [Keep the cc to the list so other can follow the issue.]
>> On 24 Mar 2020, at 11:45, Moritz Heffter <address@hidden> wrote:
>> My PATH variable shows the following:
>> /Users/username/Library/Python/3.7/bin:/opt/local/bin:/opt/local/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/TeX/texbin
>> My python3 lies in /usr/local/bin/python3. Could that be the problem?
> My path is
> /Users/username/bin:/usr/local/bin:/usr/local/X11R6/bin:/usr/local/texlive/2019/bin/x86_64-darwin:/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11/bin
> Normally, one wants the more up-to-date items earlier in the PATH, so the 
> user directory ~/bin/ before /usr/local/ which is used for installations from 
> sources, which is before /opt/, and in turn before the system paths.
> Then, I use a script to run lilypond, see
> Likewise, you might replace your custom installation by soft links, say by
> sudo ln -s <program path> /usr/local/bin/<name>
> This avoids importing the whole directory into the PATH, as you have done.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]