[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem with #port

From: Michael Albinus
Subject: Re: problem with #port
Date: Thu, 03 Jun 2004 07:26:12 +0200
User-agent: Gnus/5.110003 (No Gnus v0.3) Emacs/21.3.50 (gnu/linux)

Myron Selby <address@hidden> writes:

>>That makes me confused. It's an evidence that you didn't get loaded
>>the correct tramp. Did you set the load-path as directed in INSTALL?
> No I didn't.
> OK now I tried to load it with the --prefix=/usr/share - this creates
> a directory
> called /usr/share/share.
> I also tried it with --prefix=/usr. It complains that there is no
> directory /usr/lib/xemacs/site-packages/info/dir. In fact there is no
> /usr/lib/xemacs
> on this thing, although there is /usr/lib/xemacs-21.4.14 which
> contains the directory
> i386-redhat-linux and nothing else.
> The tramp-info files currently sits under
> /usr/share/xemacs/xemacs-packages/info.
> It seems like the directory structure differs quite a bit from what
> your install is
> expecting. It looks like I'll have to use a number of different
> variables to tell it
> where everything belongs. Unfortunately I have no idea what these variables
> are.

The --prefix works in some default cases. Because I'm using GNU Emacs,
the settings for XEmacs I've stolen somewhere, and compared with the
XEmacs sructure under Debian. If there are better defaults, please let
me know.

In your case, you should install Tramp as described in INSTALL (after

make lispdir=/usr/share/xemacs/xemacs-packages/lisp/tramp \
     infodir=/usr/share/xemacs/xemacs-packages/info \

> Thanks,
> Myron

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]