[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Cannot modify directory list GTK file dialog

From: Stephen Berman
Subject: Cannot modify directory list GTK file dialog
Date: Thu, 15 Dec 2005 01:40:41 +0100
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

I haven't used the menu or tool bars to visit files before, but I just
tried it and visiting worked, but modifying the directory list under
"Browse for other folders" didn't work.  I started emacs -q and
clicked on the file icon in the toolbar or the corresponding menu bar
entry.  At first I was able to add a directory to the list, but when I
tried to remove it, an error message window popped up which said:
"Could not remove a bookmark 
Bookmark saving failed: Could not change file mode: waitpid() failed:
No child processes" 
Then I tried to add another directory and this time it failed with the
same error message (except it said "Could not add a bookmark...").
Subseqently, even after starting emacs -q again, and even after
deleting ~/.gtk-bookmarks, no modification of the list has been
possible.  As a sanity check, I tried the same in Firefox, which uses
the same GTK dialog, and it worked fine there.  I don't know if it's
significant that, while testing the file dialog with emacs -q, I also
had an Emacs session with my initializations running (I first tried
the GTK file dialog there and found the same problems).

In GNU Emacs (i686-pc-linux-gnu, GTK+ Version 2.8.7)
 of 2005-12-09 on escher
X server distributor `The X.Org Foundation', version 11.0.60802000
configured using `configure '--with-x-toolkit=gtk''

Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_US.UTF-8
  locale-coding-system: utf-8
  default-enable-multibyte-characters: t

Major mode: Dired by name

Minor modes in effect:
  tabbar-mwheel-mode: t
  tabbar-mode: t
  recentf-mode: t
  show-paren-mode: t
  display-time-mode: t
  tooltip-mode: t
  auto-compression-mode: t
  tool-bar-mode: t
  mouse-wheel-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  unify-8859-on-encoding-mode: t
  utf-translate-cjk-mode: t
  column-number-mode: t
  line-number-mode: t
  transient-mark-mode: identity

Recent input:
<select-window> <down-mouse-5> <mouse-5> <double-down-mouse-5> 
<double-mouse-5> <help-echo> C-x k <return> C-x 1 <down-mouse-5> 
<mouse-5> <double-down-mouse-5> <double-mouse-5> <down-mouse-5> 
<mouse-5> <double-down-mouse-5> <double-mouse-5> <down-mouse-5> 
<mouse-5> <double-down-mouse-5> <double-mouse-5> <down-mouse-5> 
<mouse-5> <double-down-mouse-5> <double-mouse-5> <down-mouse-5> 
<mouse-5> <double-down-mouse-5> <double-mouse-5> <down-mouse-5> 
<mouse-5> <double-down-mouse-5> <double-mouse-5> <down-mouse-5> 
<mouse-5> <double-down-mouse-5> <double-mouse-5> <down-mouse-5> 
<mouse-5> <double-down-mouse-5> <double-mouse-5> <down-mouse-5> 
<mouse-5> <double-down-mouse-5> <double-mouse-5> <down-mouse-4> 
<mouse-4> <double-down-mouse-4> <double-mouse-4> <triple-down-mouse-4> 
<triple-mouse-4> g <down-mouse-4> <mouse-4> <help-echo> 
g <prior> <drag-n-drop> <help-echo> <down-mouse-1> 
<mouse-1> <help-echo> <down-mouse-1> <mouse-1> C <up> 
<up> <return> y g <help-echo> <help-echo> <drag-n-drop> 
<help-echo> <down-mouse-1> <mouse-1> g <up> <down> 
<drag-n-drop> <help-echo> M-x r e p o <tab> C-g M-x 
r e p o r <tab> b <tab> <return>

Recent messages:
Press C-c C-c when finished or C-c ESC to abort changes
insert-directory: Reading directory: no such file or directory, 
mwheel-scroll: End of buffer
Overwrite `/home/steve/.gtk-bookmarks'? [Type yn!q or C-h] 
Overwrite `/home/steve/.gtk-bookmarks'? [Type yn!q or C-h] y
Copy: 1 of 1
Copy: 1 file
Making completion list...
Loading emacsbug...done

reply via email to

[Prev in Thread] Current Thread [Next in Thread]