help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Oldest running Emacs version


From: Brian Masinick
Subject: Re: Oldest running Emacs version
Date: Sat, 10 May 2003 00:58:14 GMT
User-agent: Gnus/5.090018 (Oort Gnus v0.18) XEmacs/21.4 (Portable Code, linux)

Luis Fernandes <address@hidden> writes:

>     me> I'm wondering which version of Emacs is the oldest still
>     me> currently running. Please let us know.
>
>     me> (I would not be surprised if someone is still running 18.x; I
>     me> would be surprised at 17.x. I still have 19.34 installed (the
>     me> best Emacs ever released) on our system but have switched to
>     me> 21.0.106 (the 21.1 pre-test) :)
>
> In hindsight, I see that perhaps I should have worded the question
> differently. :)
>
> What I want to know is the oldest version of Emacs *still in use*.
> You know someone who refuses to upgrade their Emacs to the latest and
> are still running the version they first encountered.  For example,
> someone located the sources to Gnus 2.0 (they're up on gnus.org now)
> and perhaps this "stubborn" person is using it to read USENET on
> Emacs 18.x-- that's what I was interested in.
>
> From a personal example, i skipped Emacs 20.x entirely because of the
> Mule-Wars and happily lived with 19.34 for the longest time.
>
> (I originally forgot to xpost to comp.emacs, now added; the more the
> merrier :)

On one hand, I use both GNU Emacs 21.2 (or 21.3) or XEmacs
21.4.12 (or a similar variant), depending on which system I
happen to be logged into at any given moment.  I have a slight
bias toward GNU Emacs, but I have no aversion to either one, and
I use both of them often.

I can't remember how long ago it was, but I happened to come
across a GNU Emacs 18.55 or 19.57 implementation.  Though my very
first introduction to Emacs actually happened on a MULTICS system
and the version was prior to the creation of GNU Emacs, I
actually started using GNU Emacs regularly around the time that
18.55 came out.  I probably used 18.55 for around a year, then
moved to 18.57, 18.58 briefly, and 18.59 before starting to use
the 19 releases.  I probably used 19.28 and 19.34 more than any
other releases in that release cycle.  I think I've used all of
the version 20 releases and I've definitely used all of the
version 21 releases.

Way back in version 18, there were really basic X11 capabilities
that were implemented through the direct use of X11 Xlib calls.
As such, performance was pretty good, and overhead was modest,
compared to today's software, but the capabilities of the
graphical interface were rather limited.  The Epoch project and
the Lucid Emacs project were initiated to improve the X support.
For better or for worse, that's where the separation came between
the GNU Emacs and the XEmacs projects.

gatekeeper.dec.com, accessible through anonymous FTP, contains
many versions of GNU Emacs software.  The oldest version they
still have available is a version of 19.34.

Hope this provides you with some useful information!

-- 
Brian Masinick
mailto:address@hidden


reply via email to

[Prev in Thread] Current Thread [Next in Thread]