[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gnokii, Gnocky Error on Fedora 12

From: monet nisperos
Subject: Re: Gnokii, Gnocky Error on Fedora 12
Date: Sun, 9 May 2010 22:14:25 +0800

On Sun, May 9, 2010 at 3:04 PM, Aleksandar Kostadinov <address@hidden> wrote:

> Hi,
> Sorry but I don't understand what you mean by "Do not top post".

This is an inline reply what seems the preferred type of email reply
in this list (and many more). It saves time the reader to understand
context of the written reply. You can distinguish between top posting
(yours), bottom posting and inline replies.
btw there are lists where top posting is not considered annoying.

Hi, sorry for this, now I do understand. Again sorry.
> Anyway, I am using a laptop using windows as my OS.  I installed sun virtual
> box so I could install Fedora and ubuntu on top of windows.  The problem is,
> windows can detect my Nokia using USB cable.  The Virtual Box also detects
> my Nokia unfortunately gnokii does not.
> I will try to look for a computer with only Fedora on it so i could test my
> mobile and gnokii.. but just curious why gnokii can't identify my mobile
> while virtual box can.

You are mixing terms here. It would be hard for the gnokii team to
help you. Pawel asked you what is virtualbox and you are not
explaining to him. What does this mean that virtual box does detect
the phone but gnookii does not? What does it mean that windows detects
your phone?
To get a useful answer you first need to do your homework and ask the
question with as much details as possible.

For example:
I can access the phone with program X on windows
I can access the phone with program X on windows running inside virtual box

I am using Vista as my operating system on my laptop.  Since I only have one computer, my friend told me to install "Sun Virtual Box" which is a general-purpose full virtualizer for x86 hardware. Targeted at server, desktop and embedded use, it is now the only professional-quality virtualization solution that is also Open Source Software. In short this is an application that I can install in Windows Vista so I could install Fedora and Ubuntu without having to re-format my hard disk.  (  In this virtual box, I can install as many Linux OS as I can. 

So the case is, every time I boot on my windows Vista, I would run the "Sun Virtual Box" application.  In my virtual box, I installed Fedora 12 and it was successful, I really don't have any problem.  I updated the yum so I could install gnokii.  The gnokii version that yum installed was "Gnokii 0.6.28" version.  I also installed gnokii-smsd, gnokii.smsd-mysql.  They were all successful. 

Now, I am ready to connect my Nokia 3110 classic.  I also looked into the net if it supports AT command and it does.  I suggested by Mr. Pawel, I searched and verified the data cable I have and the data cable for Nokia 3110 classic.  So I guess, the cable that I am using to connect my phone and computer is likewise correct.

When my virtual box is already running on my vista, I connected my Nokia 3110 classic via USB and automatically windows vista detected my mobile phone after I plugged in the USB port because I already have the driver for that phone or Nokia PC suite.  When I go through my virtual box, one of the menu of virtual box is the so-called "Devices".  So I went to that menu and looked for USB devices and there I can see all the accessories connected to my USB such as my external hard disk, my mouse and my Nokia.  So that is what I am talking about.  Both Windows Vista and Sun Virtual Box can detect my Nokia 3110 classic.  Now, I tried starting "Fedora 12" by logging in as normal user.  Then I configured the "Gnokiirc  config file" as stated in the instructions I got from the Net and the files I attached is the output after executing "Gnokii --identify".  I tried also modifying the connection from gnokiirc (e.g. dku-5, dku2libusb, and serial) but still they all have same error.

Last night, as I was doing some interchanging, I come up with port as /dev/ttyACM1, model as AT and connection as dku2libusb and i was suprised because the output is somewhat different.  Error gooes like this:

Gnokii versio 0.0.28
Log: debus mask is 0x1
config read from file /home/monetteski/.gnokiirc
phone instance config:
model = AT
port = /dev/ttyACM1
connection = dku2libusb
initlength = default
serial_baudrate = 19200
serial_write_usleep = -1
handshake = software
require dcd = 0
smsc_timeout = 10
rfcomm_channel = 0
sm_retry = 0
Initializing AT capable mobile phone...
initialization failed (6)
Serial device: closing device
Telephone interface init failed: Function or connnection type not supported by phone or by the phone driver

So, with this new errors it seems that it was not able to identify the device.  I also tried executing "dmesg | tail" and I was hoping to get same results as what I got from the internet but it didn't instead it goes like this:

lo:Disabled Privacy Extensions
ip6_tables: (c) 2000-2006 Netfilter Core Team
eth0:link up, 100Mbps, full duplex
RPC: Registered udp transport module
RPC: registered tcp transport module
SELinux: initiated (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
eth0: no IPv6 router present
metacity[1178]: segfault at 616d2078 ip 0087591 sp bf89fd30 error 6 in[874000+7000]
fuse init (API version 7.12)
SELinux:initiatized (dev fuse, type fuse), uses genfs_contexts

Although probably I'm losing my time right now given I'm not a gnokii
expert and that there's a great lack of details, I'd ssuggest to you
to look at your fedora's log while connecting the phone and see if the
USB layer detects the device. If you see some usb related messages,
then look if the necessary device that you have configured in your
gnokii config is created. If not, see if you have installed the udev
rules necessary to create this device.
With lack of linux knowledge it's not an easy task but asking
linux/fedora specific questions in the fedora user forum can certainly
help you.

Sorry for the things I caused the group. 
gnokii-users mailing list


reply via email to

[Prev in Thread] Current Thread [Next in Thread]