[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gnokii, Gnocky Error on Fedora 12

From: monet nisperos
Subject: Re: Gnokii, Gnocky Error on Fedora 12
Date: Wed, 12 May 2010 14:37:43 +0800


On Mon, May 10, 2010 at 2:39 PM, Aleksandar Kostadinov <address@hidden> wrote:
On Sun, May 9, 2010 at 5:14 PM, monet nisperos
<address@hidden> wrote:
> computer, my friend told me to install "Sun Virtual Box" which is a
> general-purpose full virtualizer for x86 hardware. Targeted at server,
> desktop and embedded use, it is now the only professional-quality
> virtualization solution that is also Open Source Software. In short this is

Sorry, but there are also KVM and Xen that are professional quality
and fully supported in enterprise deployments by vendors like Red Hat,
Novell, xensource, Oracle and perhaps others. btw Sun is now part of

To make things easier for me, I got PC and installed Fedora 12 on it and gnokii.  This time I have no windows anymore.  Then I tried connecting my Nokia 3110 classic and PC via mini USB.  Once nokia is connected, it gave me 3 options on my mobile whether to connect thru: 1. Nokia mode, 2: printing and media 3: data transfer.  So, I tried choosing option 1 and tried executing "dmesg | tail".  The result was:

usb6-2: USB disconnect, address 3

usb6-2: new full speed USB device using uhci_hcd and address 4
usb6-2: new USB device found, idVendor=0421, idProduct=005e
usb6-2: new USB device strings: Mfr=1, Product=2, Serial Number=0
usb6-2: Product: Nokia 3110c
usb6-2: Manufacturer: Nokia
usb6-2: configuration #1 chosen from 1 choice
cdc_acm 6.2.1: ttyACM0: USB ACM device
usb6-2: bad CDC descriptors

So this means that my PC can detect my nokia.  So , I tried executing "gnokii --identify" but I set my configuration to like model = series40, connection = dku2libusb and port = 1 just like indicated in cables - Gnokiiwiki.  The result was:

Gnokii version 0.6.28
Log:debug mas is 0x1
config read from file /home/monette/.gnokiirc
phone instance config
model = series40
port = 1
connection = dku2libusb
initlength = default
serial_baudrate = 19200

Serial device: opening device USB
ignoring extra header, type 171, length 5
found FBUS interface
can't set configuration: -1
cant claim control interface: -1
couldn't open PHONET device: operation not permitted
error in link intialization:1
telephone interface init failed: command failed
Command Failed.

Still, gnokii can't identify my mobile.  CAn you please help me analyze the error and so I could make the right configuration?

Anyways, you need to check if you have downloaded the non-opensource
installation binaries because IIRC only they are providing the USB
passthrough to the virtual machine. Also you need to see how to
configure virtual box so it makes the USB available to the virtual
Another option for windows to run linux would be the free (but not
open source) vmware player which also should support USB to the
virtual machine.

gnokii-users mailing list

Masters in Global Information and
   Telecommunication Studies,
Waseda University
Honjo-shi, Saitama, Japan
Mobile no: (81) 80-4143-7019
Email Add: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]