[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guix pull: error: symlink: File exists

From: Thorsten Wilms
Subject: Re: guix pull: error: symlink: File exists
Date: Tue, 30 Oct 2018 21:02:55 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.2.1

On 30/10/2018 19.16, Laura Lazzati wrote:
        At the same time, a `sudo guix pull` works fine.

    Thanks for this finding.

Sorry, I thought this fixed it for me too, but now every time I run an installed package, I get that guix is 18 days old,  asks me to guix pull, and if I run even the hello package, i get that it is not installed and claims to install it with, in my case, apt.

Sorry Laura, I did not mean to suggest that this was a fix. It's just that `guix pull` for the root profile stayed functional. My own plain user `guix pull` still results in the same old:

Migrating profile generations to '/var/guix/profiles/per-user/thorwil'...
guix pull: error: symlink: File exists: "/var/guix/profiles/per-user/thorwil/current-guix-1-link"

Looking for an explanation for having user and root profile guix, since you seem to be unaware of how that works and I can't be sure of my own understanding, I found something related:

Thing is, I did
`ln -s /var/guix/profiles/per-user/root/guix-profile/bin/guix
during installation and that symlink is still intact. Yet, `guix pull` and `sudo guix pull` are markedly different.

Thorsten Wilms

thorwil's design for free software:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]