[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [libmicrohttpd] Building libmicrohttpd-0.9.55 on RHEL5

From: Svein Olav Bjerkeset
Subject: Re: [libmicrohttpd] Building libmicrohttpd-0.9.55 on RHEL5
Date: Wed, 27 Sep 2017 09:37:31 +0200
User-agent: Roundcube Webmail/1.2.1

Latest git contains some fixes for epoll modes.
Could you fetch source from official git on other platform (autoconf on
RHEL5 is too old), run "autoreconf -i && ./configure && make dist-gzip".
Then build from resulted tarball on your RHEL5 machine?

Most probably GnuTLS is not yet well polished on your machine.

For testing connectivity I'd recommend to use RHEL/CentOS 7 or latest
Debian. Also same platforms are recommended to fetch sources from git.

I presume it was libmicrohhtpd you wanted me to check out from git and not one of the support libraries? I have now tried that, without any luck. It still behaves as before. I have also tried to use curl and wget from a RHEL7 server as suggested. Results are still the same.

Here is the configure command I used:
# export CPPFLAGS="-I/opt/microhttpd/include"
# export LDFLAGS="-L/opt/microhttpd/lib64 -Wl,-rpath,/opt/microhttpd/lib64" # ./configure --prefix=/opt/microhttpd --libdir=/opt/microhttpd/lib64 --with-gnutls --enable-https=yes --with-libcurl=/opt/svv-dev

(in /opt/svv-dev is a modern curl, version 7.55.1)

I also tried --disable-epoll without any noticable change.

Best regards,
Svein Olav Bjerkeset

reply via email to

[Prev in Thread] Current Thread [Next in Thread]