[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Q: metafont not being called unless i run xdvi

From: David Petrou
Subject: Re: Q: metafont not being called unless i run xdvi
Date: Tue, 24 Dec 2002 12:43:26 -0500
User-agent: Mutt/1.2.5i

> I definitely recommend 1., building Lilypond without kpathsea is
> asking for problems.

well, i did that, and now my pdf output is completely mangled.

i installed tetex-devel which has kpathsea.  (i had to force install
this rpm because my tetex installation was in a weird place that rpm
didn't find.)

then, in my lily 1.6.6 dir i did:
make uninstall
make distclean
./configure --blah
make all
make install

then i ran
make pfa-fonts
make MAKE_PFA_FILES=1 install

like you suggest in

all of these commands terminated correctly (that is, they returned 0
to my shell).  ./configure found my kpathsea and everything...

now, running ly2dvi -p on a perfectly good ly file, i get pdf output
when things like the letter 'l' for the trebel clef, the letter 'j'
for the bass clef, etc.  the only output that is correct is the
horizontal and vertical lines of the staff, and things like beams.
noteheads come up as exclamation marks.  this is really fun.  the only
good thing about this is that everything is infinitely scalable; there
are no jaggies when i zoom in really far.

any idea what went wrong?  should i try installation premade pfa
files?  if so, how?

>     /Mats

happy holidays,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]