[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Q: metafont not being called unless i run xdvi

From: David Petrou
Subject: Re: Q: metafont not being called unless i run xdvi
Date: Mon, 23 Dec 2002 20:12:23 -0500
User-agent: Mutt/1.2.5i

> You have to build or download the Type1 version of the fonts, 
> since that's what ly2dvi -p uses avoid the fuzzy looking
> bitmapped fonts in the PDF files. 
> Read 
> for instructions on how to build and install the fonts.

doh.  i blowed away my lilypond trying to do this.  luckily i made a
backup first.

this is what happened: a while ago i installed lily 1.6.6 on a suse
7.x machine whose tetex had kpathsea.  my machine was upgraded to suse
8.0 by computing facilities.  for some reason, the tetex on this
version doesn't have kpathsea:

bwv988 0/226 share/image/usr/local/teTeX> find . -name '*kpathsea*'

so, when i tried the commands you suggest in that e-mail you cited, i
ran into problems.  so i searched for an rpm of kpathsea-dev or whatever.
the only one i found had kpathsea headers, but no .so.  so i still
couldn't ./configure lily to use kpathsea; it would die trying to find
the library.

fine, i ./configure lily -without-kpathsea to see how far i get.  i
manage to get the pfa font files created.  when i try to install them,
the make system decides to remake and install my lily without kpathsea
support, which i think is what's causing the following error:

  ly2dvi -p
  Running LilyPond...
  GNU LilyPond 1.6.6
  Now processing: `'
  Interpreting music...
  MIDI output to `wreckers_dec_2002.midi'...
  Track ... 
  error: can't find `feta20.afm'
  Fonts have not been installed properly.  Aborting

  LilyPond failed on an input file (exit status 1).
  Trying to salvage the rest.

  warning: no LilyPond output found for `wreckers_dec_2002'

so, i think my options are:
1. find out some way to get a complete kpathsea-dev for tetex 1.0 and
redo the lily installation completely.
2. revert to my backup and figure out what files to copy from my build
directory to it to have the pfa files in the right place.
3. revert to my backup and find han-wen's email on installing prebuilt

of course, i should have done 3 to begin with.  it took hours for me
to install all the programs that mftrace depended on.

i'm looking forward to getting this done, though; it's killing two
birds with one stone: (1) my program viewing pdf without first running
xdvi to create the fonts, and (2) getting infinitely scalable fonts
for great on-screen viewing.

>     /Mats


reply via email to

[Prev in Thread] Current Thread [Next in Thread]