[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: help with installation

From: Laura Conrad
Subject: Re: help with installation
Date: 03 Mar 2002 10:48:26 -0500
User-agent: Gnus/5.0808 (Gnus v5.8.8) XEmacs/21.4 (Artificial Intelligence)

>>>>> "Michael" == Michael J McGonagle <Michael> writes:

    >> urpmf
    >> and it will tell you what package provides that file (the answer I get
    >> here is libintl1).

    Michael> Comes back with nothing for me...

That's because your database is hosed.  Try installing libintl1.  (put
in your CD, cd to /mnt/cdrom/Mandrake/RPMS* and say:

        rpm -Uvh libintl1*

If it's not on the first disk, you have to try the others.

    >> Another thing to try, which stopped working for me on 8.0 but may
    >> still work for you is:
    >> urpmi lilypond

    Michael> Does this require that I run as root? I tried as a normal
    Michael> user and it tells me that "Permission Denied".

Yes, you need to be root, on my system.  Part of the advertised
feature set of urpmi is that it allows non-root users to install from
trusted sources, but apparently that isn't set up by default.  

    Michael> Running as root, it comes back with "no package named lilypond".

I get that too.  I guess they didn't put the lilypond rpm on their

    Michael> Laura, I have tried to find a good tutorial on using
    Michael> 'rpm', it appears that you are a LOT more fluent than I
    Michael> am, could you recommend a tutorial?

You should start with the man pages for rpm, urpmi and urpmf.  There's
a book called "Maximum RPM" which is online; you can find it with
google or from the redhat site.  It's more information than you want,
but the advantage of a book with an index is that you can sometimes
find what you want more easily than with all this newfangled searching
technology.  There's also a site that has unofficial mandrake support
( with a good document on how to fix up the
rpm database, which didn't help me but may help you, and certainly
explains things better than the man pages.

And having said all this about RPM, I think it really makes more sense
with something that changes as often as lilypond (even the "stable"
version gets an update every month or so) to forget about RPM and
compile it yourself.  Even after telling Mandrake I wanted a developer
workstation, I still had to install a bunch of stuff (bison and yacc
come to mind), but I think I checked after I had it working and it was
all listed in the INSTALL directions.  (No, I didn't read the INSTALL
directions before installing; I'd been installing for years.)  But you
do need to get a working package manager one way or another.

Laura (mailto:address@hidden , )
(617) 661-8097  fax: (801) 365-6574 
233 Broadway, Cambridge, MA 02139

reply via email to

[Prev in Thread] Current Thread [Next in Thread]