[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] qemu crashes at boot start

From: Robin Pfeifer
Subject: Re: [Qemu-devel] qemu crashes at boot start
Date: Fri, 25 Mar 2005 22:38:59 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7.5) Gecko/20041220

This has been discussed as 'qemu problem (you might be my last resort)', but the new topic line is probably a little more informative. I'd like to subsume the error once more, maybe someone has an idea who ignored the less-informative previous title.

I am trying to boot live CDs or the freedos.img as available on the qemu homepage. It used to work perfectly a couple of months ago, and back then I aliassed the command

livecd='qemu -cdrom /dev/cdrom -boot d -snapshot'

When I added more RAM about a month ago, I added '-m 350' to this command. After that, qemu wouldn't work anymore, not even when I left out the -m parameter. Instead, qemu now immediately stops (the window displaying 'qemu stopped' in its title) and cannot be closed with anything other than ctrl+c in the console from which it was started. Not even the BIOS messages turn up. Using the parameter -S I can stop the emulation before the crash and get into the monitor, but as soon as I enter c in order to continue the window freezes. Meanwhile I have also tried gdb as described in the documentation, but as soon as I enter c there, same thing: qemu window freezes.

If I use a wrong parameter so that booting fails, the BIOS messages do appear up to the obvious point where booting cannot commence. So:

qemu -cdrom /path/to/freedos.img

boots until ' FATAL: Could not read the boot disk'

Same goes for any attempts to boot a live CD with -hda /dev/cdrom

But if I use -cdrom for /dev/cdrom or -hda for the freedos.img, I get the freeze. Apparently qemu crashes on my system as soon as it finds something it should be able to boot.

I have tried various dad-answers snapshots and now I have 0.6.1 again. I have deleted all files with qemu int heir names between installations. I have deleted the content of /tmp and even temporarily moved both /tmp and /var somewhere else in order to check whether there might be a temporary file blocking the process, but nothing changed anything. Qemu is no longer working for me.

I'm grateful for any suggestions you might have.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]