[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] qemu problem (you might be my last resort)

From: Robin Pfeifer
Subject: Re: [Qemu-devel] qemu problem (you might be my last resort)
Date: Sun, 20 Mar 2005 21:49:34 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7.5) Gecko/20041220

Jim C. Brown schrieb:
On Sun, Mar 20, 2005 at 08:01:04AM +0100, Robin Pfeifer wrote:

Out of curiosity, does it work if you use an iso image instead of
No, it doesn't, the same error appears.

If you "-boot a" from a floppy disk image, will that work or does it
have the
same error? (You can download a FreeDOS boot disk if u don't have a
way to
get a bootable floppy disk image).
That's very strange, booting from a floppy works.

You mean u get the new X window titled "QEMU", which shows the guest OS booting,
and once the booting is done the guest OS is actually usuable (at least as
usuable as it would be if it was botted on a real computer)?

Not quite. The first disk I tried was a very old DOS 6.0 I still have lying around (I haven't got that many boot floppies anymore), and it didn't quite finish booting - but I thought, maybe the disk is broken. But I have also tried a Linux-based floppy which I have used as a boot disk previously, and downloaded bootE and tried that, too - I'm finding the kernel simply stops booting after a while. It does boot normally during a real boot process.

But that still goes much farther than booting a cdrom image, as I actually get to see the BIOS being set up and the kernel being started. With a cdrom or image of such I immediately get a blank screen.

Here are a few more tests to try out:

If you boot from a hard disk, no floppy or cdrom image given, does it work?

Hm, would that be something like 'qemu -hda /dev/hda1 -snapshot -m 256'? That gives me the same error as booting from a cdrom. hda1 should be a Win2000 system. When I enter a disk which is present but not bootable (for instance sda1, where my Linux system is located, which I boot from a floppy), the BIOS does appear until the obvious error message turns up that there is no system on the disk. The qemu window remains responsive and can be closed - the crashed window I get when trying to boot something bootable cannot be closed except with xkill or Ctrl + c in the terminal from which I started it.

It appears that qemu becomes weird when it encounters a boot block - though that doesn't explain why it does boot floppies at least up to a point.

That makes the remaining tests obsolete, I suppose...

If you boot from a hard disk, cdrom iso image given, does it work? If it does
work, can you see the cdrom from the guest?

If you boot from a hard disk, /dev/cdrom given, does it work? If it does
work, can you see the cdrom from the guest?

If you boot from a floppy, cdrom iso image given, does it work? If it does
work, can you see the cdrom from the guest?

If you boot from a floppy, /dev/cdrom given, does it work? If it does
work, can you see the cdrom from the guest?

I'm trying to see if this problem is caused by trying to access the cdrom,
or if it only comes up when you try to boot from it. (BTW how many different
cdroms/cdrom images have you tested?)

I have tested a couple of live CDs, Knoppix, Kanotix, RescueCD, Insert, SuSE... all of which boot correctly the normal way. the Knoppix and Insert CDs I actually booted a couple of times successfully with qemu, too, before qemu began to fail me.

Stefan Kisdaroczi wrote:

Did you try to set "-L" ?
-L path  // set the directory for the BIOS and VGA BIOS
No, I didn't try that. This parameter isn't in the qemu manpage, is it? What am I supposed to use as directory?


-L is used to set the path for the BIOS. This directory is the one that contains
the following files:

bios.bin            ppc_rom.bin         vgabios.bin
linux_boot.bin      vgabios-cirrus.bin

E.g. if you installed to /usr/local prefix, the BIOS files are probably in

Since booting from a floppy works, I do not think that this is a BIOS related
problem (unless you are using an old bios.bin file or somehow your bios.bin
file got slightly corrupted by mistake).

If they got corrupted, they should have been replaced by now. I deleted all files and directories with 'qemu' in the name and installed qemu fresh during my attempts to get rid of the error. And the floppies at least boot past the BIOS, too.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]